0

I have 2 problems lately regarding IPv6: My ISP doesn't provide an IPv6 prefix (even with modem in bridge, and yes the ISP supports) so, I'm using SIXXS tunnel , it doesn't attribute IPv6 to another OpenWRT in my LAN despite all other devices are OK. Any ideas in how do I start to troubleshooting that?

Here is my network: Both TP link are using OpenWrt Chaos Calmer 15.05, Firewall is default.

ISP Modem (bridge) <--PPPoE-->TP-Link TL-WDR4300 v1<-LAN->TP-Link TL-WA901N/ND v3

TP-Link TL-WDR4300 (/etc/config/network)

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
        option ifname 'eth0.1 tap_myvpn'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.72.1'

config interface 'wan'
        option ifname 'eth0.2'
        option _orig_ifname 'eth0.2'
        option _orig_bridge 'false'
        option proto 'pppoe'
        option username 'xxxxxxx'
        option password 'xxxxxxx'

config interface 'wan6'
        option _orig_ifname 'eth0.2'
        option _orig_bridge 'false'
        option proto 'dhcpv6'
        option ifname 'eth0.2'
        option reqaddress 'try'
        option reqprefix 'auto'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 2 3 4 5'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 1'

config interface 'SIXXS'
        option _orig_ifname 'eth0.2'
        option _orig_bridge 'false'
        option proto 'aiccu'
        option username 'xxxxxx'
        option password 'xxxxxxx'
        option tunnelid 'xxxxxxxx'
        option heartbeat '0'
        option requiretls '0'
        option ip6prefix '2001:1291:XXX:XXXX::/64'
        option ip6addr '2001:1291:XXX:XXX::2/64'
        option verbose '1'
        option nat '0'
        option ntpsynctimeout '0'
        option metric '50'

config interface 'clients'
        option _orig_ifname 'wlan0-1'
        option _orig_bridge 'false'
        option proto 'static'
        option ipaddr '192.168.0.1'
        option netmask '255.255.255.0'

config route
        option interface 'lan'
        option target '192.168.72.1'
        option netmask '255.255.255.0'

config route
        option interface 'clients'
        option target '192.168.0.0'
        option netmask '255.255.255.0'
        option gateway '192.168.72.1'

TP-Link TL-WA901N/ND v3 (/etc/config/network)

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd0a:abd9:4b90::/48'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option _orig_ifname 'eth0 radio0.network1'
        option _orig_bridge 'true'
        option proto 'dhcp'

config interface 'clientes'
        option _orig_ifname 'wlan0-1'
        option _orig_bridge 'false'
        option proto 'static'
        option ipaddr '192.168.0.1'
        option netmask '255.255.255.0'

config route
        option interface 'lan'
        option netmask '255.255.255.0'
        option target '192.168.72.201'

config route
        option interface 'clientes'
        option target '192.168.0.0'
        option netmask '255.255.255.0'
        option gateway '192.168.72.201'

config interface 'LAN6'
        option proto 'dhcpv6'
        option ifname 'eth0'
        option reqaddress 'try'
        option reqprefix 'auto'
2
  • 1
    You don't seem to have configured your /48 network? Mar 2, 2016 at 0:32
  • You double NAT ? and is it a lab ? I ask because of openwrt, if a router break and you can't find a router compatible openwrt, whats your plan b ? as the warranty is now null'd on the tp-link too. For me this is not a professional scenario because of that.
    – yagmoth555
    Mar 2, 2016 at 3:35

0

You must log in to answer this question.

Browse other questions tagged .