Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a failed 750GByte SATA Seagate drive which has failed within the first year of it's 3 year warranty.

The Seagate warranty site stresses the importance of testing the drive with "SeaTools" (and obtaining some diagnostic error code) before returning it.

If I attempt to boot up a machine (Dell T5400, XP64) with the drive connected by a SATA cable, the machine doesn't get past POST (waited 5+ mins to see if there was a timeout... maybe should have waited longer?). If I disconnect the drive, disable that SATA channel and reboot it still doesn't post. If I disconnect the drive I can boot, but if I hotplug the drive once past POST SeaTools doesn't detect it.

Is the drive just very dead (too dead for SeaTools to even notice it) or is there some way I can get it to be visible to SeaTools ?

I've tried the drive in 2 machines. The other one does eventaully POST after a couple of minutes (and there's no hint of the drive in the BIOS's view of drives), but is a Linux box (so no SeaTools).

share|improve this question

3 Answers 3

up vote 4 down vote accepted

I'd tend to agree with your "very dead" assessment-- especially if you can get the same behavior out of another machine.

I have seen the failure mode you describe with failed SATA and PATA disks on various machines going back into the late 90's. I don't know the specifics of the communications protocol used by ATA devices, but it certainly seems to be a lot more prone to a "crazy" device causing the kinds of issues you're seeing than, say, a SCSI device.

Seagate has taken returns from me, in the past, with a trouble reporting indicating that SeaTools could not be run because the BIOS either did not detect the drive or would not POST with the drive attached. Your luck, obviously, may vary.

share|improve this answer
1  
Seagate has alos taken returns based on the fact that the systemn is "dead" and you cannot run SeaTools. Somettimnes a secind call gets a different agent with a different attitude or understanding of the nature of things. –  Dave M Jan 6 '10 at 15:06
    
The return authorization system had some option like "system won't POST" so I picked that. They sent me a replacement drive. –  timday Apr 18 '10 at 9:29

You can say on the RMA form that you're running a Mac, and since they don't provide SeaTools for Mac, they waive the requirement for a SeaTools diagnostic code.

I got a drive replaced a few weeks ago and this was my experience.

share|improve this answer

I had same issues with dell vostro 1520 what i have done here i got fedora 12 live cd got my all data back from 250GB hdd.

share|improve this answer
    
Data recovery isn't an issue: the failed drive was one half of a RAID-1ed pair, already restored from degraded mode with a fresh (non-Seagate!) drive. Hurrah for RAID1! Actual downtime on the production system was maybe 20 mins. The question is about getting Seagate to honor their warranty and the problem of running Seatools when a system with the drive in won't post. –  timday Jan 7 '10 at 10:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.