Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Hi I bought my first Virtual Private Server, mainly with the aim of learning about managing a server. I don't have any entries in my iptable, it's totally open but I still cannot to my server on ports other 80, 21 etc. For example I changed the port in httpd.conf from 80 to 90 and then from external host tried connecting to http://mywebsite:90 and it is not working.Within the localhost(i.e through ssh shell) I'm able to telnet to localhost 90 but only from outside it's not working. Is there any other firewall in CentOS other than iptables? Also does usually VPS providers block certain ports. I was of the impression since having a unique IP I would be full open in the internet. As part of my VPS there is a HYPERVM control panel but I couldn't find any option to open ports.

--ADDED--- Here is my output of iptables -L

Chain INPUT (policy ACCEPT)
target     prot opt source               destination

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination

Regarding apache I just changed to 90 to test if it works. I did it by changing listen 80 to listen 90. When it was in listen 80 it was working fine. Actually I figured this problem when I couldn't access webmin which runs on port 10000. So I just changed in apacha to confirm it.

share|improve this question

Try stopping the iptable service entirely.

share|improve this answer
This is one of the first things you should try. If it works you know you need to alter something in your iptables config. #/sbin/service iptables stop # test if it works now # /sbin/service iptables start – Powertieke Feb 12 '10 at 14:46

I bet your problem is in your Apache configuration. There's probably a directive that is only allowing traffic from your localhost.

Update your question with your apache config file and a listing of your iptable rules. Then someone can probably provide you a solution to your problem.

share|improve this answer
I'm having two interaces other lo venet0 and venet0:0. The venet0:0 is the interface with the public IP. – Sarat Balachandran Jan 6 '10 at 20:45
Can you ping the IP for the venet0:0 interface? – 3dinfluence Jan 6 '10 at 21:10
Yes I can ping the IP from outside. But I can only connect to the standard ports from outside. From the shell I can connect to the other ports also. – Sarat Balachandran Jan 6 '10 at 21:44
What does your directory options look like in your apache config. In particular the order and Deny and allow lines. – 3dinfluence Jan 7 '10 at 2:42

Have you asked your provider which ports are allowed? Perhaps the provider has a central firewall which only allows some port like http or ftp for the vps.

share|improve this answer
Theres a good way to test that. If you're being blocked by a firewall you'll typically see a "connection refused" error when telneting to that port versus a "connection timed out" which generally indicates that nothing is listening on that port. – Sergio Jan 7 '10 at 0:43

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.