Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After rebooting my machine, I have found many services have stopped starting automatically. If I start them with their init scripts once the machine is booted, they start without any problems. Strangely enough, if I run sudo init 5 once logged in, most services will start (although some still seem to refuse without manually running their init scripts.

I can't think of anything that's changed since I last rebooted my machine and system logs don't seem to show anything useful. Any help is always appreciated!

Update: I have verified both by using chkconfig and examining scripts in /etc/rc*.d folders that the services are configured to start and that the scripts run correctly.

share|improve this question
up vote 3 down vote accepted

This is a confirmed bug of 9.10. See

I changed the line 9 of /etc/init/rc-sysinit.conf from "start on (filesystem and net-device-up IFACE=lo)" to "start on filesystem and net-device-up". It's worked for me.

share|improve this answer
I'll check the system when I get into the office today, but this sounds exactly like what I'm experiencing. – Michael Mior Jan 18 '10 at 13:18
Thanks! I tried updating /etc/init/rc-sysinit.conf as you suggested,which didn't help. However, updating /etc/network/interfaces as suggested in the bug report did the trick! – Michael Mior Jan 18 '10 at 15:34

Have you verified the services are activated for your default runlevel? You can get your current runlevel with runlevel. You can verify the activated runlevels with chkconfig --list <servicename>.

share|improve this answer
chkconfig isn't installed by default in Ubuntu; you need to install the chkconfig package. – womble Jan 7 '10 at 0:56
This isn't an answer and should be posted as a comment. But yes, I have verified that the services are activated. – Michael Mior Jan 7 '10 at 15:47

How did you add those services? Usually with Ubuntu you add and/remove links to the rc services with the update-rc.d command:

root@hostname:~# /usr/sbin/update-rc.d
usage: update-rc.d [-n] [-f] <basename> remove
       update-rc.d [-n] <basename> defaults [NN | SS KK]
       update-rc.d [-n] <basename> start|stop NN runlvl [runlvl] [...] .
       update-rc.d [-n] <basename> disable|enable [S|2|3|4|5]
                -n: not really
                -f: force

I'd try to update the init scripts in question with that command to see if that addresses.

Now if the services were not added via apt-get and your installed them manually, that's a different story. Which services in question did not start?

share|improve this answer
All the services were installed automatically with apt-get and were previously working. Services that didn't start include ssh, webmin, monit, and several others. I don't have a complete list. (As an aside, I installed monit AFTER I had this problem and it also does not start) – Michael Mior Jan 7 '10 at 18:05
I could be wrong, but it sounds like its at init 1, since most of the multi-user servers start at around 2 (for Ubuntu , at least): root@host:~# who -r run-level 2 2009-12-29 05:47 I thought that it is set to level 1 by accident, but as it turns out, there is no inittab for some time. :( that said, you may want to check anyway and if you see that it has been installed, change it to either level 2 or 3. – Rilindo Jan 7 '10 at 20:22

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.