Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've configured Apache to use mod_auth_kerberos. So far everything is working nicely for client thats connected to Active Directory and have their browser to ntlm enabled.

When clients are not in the domain or the browser configurerd not to authenticate automatically, they are being prompted by 2 login prompt.

The first login prompt is blank and the second one is the oen that we configured

First Login prompt: http://www.screencast.com/t/ZGNlZTQwZm
Second Login prompt : http://www.screencast.com/t/MDA2N2Fl

From the log ( first authentication) :

[Wed Jan 06 15:47:29 2010] [debug] src/mod_auth_kerb.c(1684): [client x.x.x.x] [pid 2562] kerb_authenticate_user entered with user (NULL) and auth_type Kerberos

In the first loging prompt , I can put any text for username and password. Once the first login form submited, it will ask for the 2nd login prompt.

Apache have following config :

<Directory /web/apache2/htdocs>
    AllowOverride All
    AuthType Kerberos
    AuthName "Staff Access ONLY Kerb-Auth"
    KrbAuthRealms EXAMPLE.COM
    Krb5Keytab /etc/httpd/conf.d/example.ktab
    Allow from localhost
    Require valid-user
<Directory>

What could be the cause of the first authentication and how can I get rid of them ?

share|improve this question

2 Answers 2

(Can you post an answer if you figured it out?)

share|improve this answer
    
Will do .. up to today its still prompt authentication twice .. –  Rianto Wahyudi Feb 17 '10 at 1:05

Only IE will prompt you twice. For example Firefox will only present the configured login prompt. To solve this you will have to add the specific website to your "local intranet" or to your "trusted sites" (Internet Options -> Security tab -> "Local Intranet"). I'm not sure anymore which one but I thought it was the "local intranet".

share|improve this answer
    
I can see the same behaviour across ie, firefox, opera, and chrome. –  Rianto Wahyudi Oct 14 '10 at 4:42
1  
The issue im having is not how to get SSO working, but when SSO is not possible ( ie external user trying to connect ) it prompted authentication twice. –  Rianto Wahyudi Oct 14 '10 at 4:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.