Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

The system I am working on started to randomly reboot, thinking it was a harddrive error (we've had two machines fail due to this already), I rebooted the computer to run chkdsk.

Now the problem is that waiting the 1.5 hours for CHKDSK to complete, causes it to reboot without finishing, and hitting any key to skip CHKDSK blue screens with PAGE_FAULT_IN_NONPAGED_AREA.

Booting into safemode hangs on AGP40.sys, but booting the computer normally before I tried to do CHKDSK worked until it decided it was time to reboot itself.

Anyways, my goal is to simple disable the automatic CHKDSK on bootup. While speculations as to the root cause of this issue is welcome, the only thing I'm currently concerned with is getting the machine up temporarily.

And with CHKDSK running at bootup causing a crash, that is difficult.

I have learned how to do a LoadHive, however I have no idea which registry I file I need to load from C:\Windows\System32\Config\ nor where in that file I can load it from.

I currently have the harddrive in another machine, so I can do a loadhive, or do some config file modifications if necessary.

Side Note: Hardware is fine, moved harddrive to another machine and still fails to boot for the same reasons (while that machine boots just fine with it's own harddrive).

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I believe it is set in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\BootExecute

Sounds like you have bad hardware on that box, motherboard or powersupply is likely.

Excerpt from http://www2.isye.gatech.edu/~mgoetsch/cali/Windows%20Configuration/Windows%20Configuration%20Html/ModifyingDefaultBootupRunofCHKDSK_F.htm

Normally it is set to

autocheck autochk *

To prevent CHKDSK /F from running for NTFS partition D: the entry becomes:

autocheck autochk * 
autocheck autochk /k:D

To force CHKDSK /F for drive D: when the Dirty Bit was not set the entry becomes

autocheck autochk * 
autocheck autochk /m:D
share|improve this answer
    
Thanks, trying this using LoadHive, it's not a hardware problem though, added a note to the bottom of my question. –  Brett Allen Jan 7 '10 at 16:55
    
Successfully fixed my problem, thank you. –  Brett Allen Jan 7 '10 at 18:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.