Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I virtualized an existing Windows XP partition using VMWare Converter, and I am running it from within a Windows 7 host. The original system had XP on drive C: and a large data drive on D: (too large to virtualize).

From within VMware Player (before starting the VM), I go to Virtual Machine Settings, Hardware tab. I click Add and add a new hard disk. The wizard steps are "Add Hard Disk", "Use A Physical Disk", select physical drive and individual partition, then check the partition corresponding to the desired D: drive.

After making these changes and attempting to start the VM, VMWare player gives an error about not being able to connect, and then hangs.

I also tried a different approach using Shared Folders. Under the Virtual Machine Settings, Options tab, "Shared Folders" lets me map the D: Drive as a shared folder, but from withing the VM, it appears as a network resource, with a UNC path like "\VMware\long\unc\path". Unfortunately, programs that are expecting D:\ will not work with that.

What is the procedure to access a host drive and map it as a physical drive letter from VMWare player?

share|improve this question
add comment

1 Answer

After further searching with various keywords combinations, I came across this article:

The key phrase is:

You can map a shared folder to a drive letter just as you would with a network share.

How to get your "other" drive to appear with the proper letter -

  1. From the VMWare Player menu: VM / Settings / Options Tab / Shared Folders.
  2. Click Add and enter the drive lettter (D:) as the host path. Enable the share.
  3. From a Windows Explorer Window in the guest OS, map the desired drive letter to the VMWare share. It will appear in the Network tree as a new level called "VMware Shared Folders" below "Microsoft Windows Network".
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.