Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Recently (eg. in the last week or two), when I RDP to one of our servers running Windows Serve 2003 64bit, the login screen is black.

If you can guess what it is prompting, then you can still login, and once you get past the login screen the desktop displays correctly.

Any suggestions as to what would have caused the login part to be blank?

-dave

share|improve this question

3 Answers 3

up vote 3 down vote accepted

Like this?

From KB 906510:

This issue occurs if all the values under the following registry subkey are set to "0 0 0": HKEY_USERS.Default\Control Panel\Colors

Note: The value data "0 0 0" means black.

Export the registry subkey from another Windows Server 2003-based computer

  1. Click Start, point to Run, type regedit in the Open box, and then click OK.
  2. Locate the following registry subkey: HKEY_USERS.Default\Control Panel\Colors
  3. Right-click the Colors registry subkey, and then click Export.
  4. In the File name box, type a name for the file.
  5. Note the location where you will save the file, and then click Save.

Import the registry subkey into the affected computer

  1. Click Start, point to Run, type regedit in the Open box, and then click OK.
  2. On the File menu, click Import.
  3. Double-click the .reg file that you want to import.
  4. Quit Registry Editor, and then restart the computer.
share|improve this answer

I really wouldn't be able to tell if this is client or server related, but as a start:

[Server]

I would check the RDP settings against another server, as well as the resultant set of policy against another server as it applies for "Computer Configuration\Administrative Templates\Windows Components\Terminal Services"

[Client]

Make sure you have RDC 6.1, and then try turning various graphical optimisations off/on.

share|improve this answer

Check out in Safe Mode .. same?

I think the color scheme might be messed up, so go in via Safe Mode or however you can, and change that :)

You can update in the registry as well ...

HKEY_USERS.DEFAULT\Control Panel\Colors

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.