Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Anyone got a problem with php 5.2.12 getting a lot of " Maximum execution time()" error when trying to include files?

I can't seem to find the bug in php.net, but it's consistently giving us that error on numerous scripts.

Anyone can recommend solutions?

share|improve this question
    
Are all the scripts including the same file(s)? What's in the file(s) you're including? You could do some profiling with xdebug.org and see what shows up in there. –  LukeR Jan 8 '10 at 3:40

3 Answers 3

It looks like the file that you are including is running some functions or codes that are taking time.

Include function it self do not take time. Instead its inside the file that you are including.

I would suggest you to check that first.

share|improve this answer

Have you checked the max_execution_time variable in php.ini? That is the maximum amount of time a script can run. I don't know if there are any settings specifically for includes.

share|improve this answer

Is there an IO problem when trying to get the file? Is the file local or on a NAS? Try including the file in a script by itself to make sure your not hitting a bug in your code somewhere else.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.