Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I was just trying to check out one of my websites on IE6, and I receive an error saying "Internet Explorer cannot open the Internet site... Operation Aborted".

Now it turns out that when I try the same site on Firefox on the same machine (VirtualBox WinXP VM) it works. Other websites I host on the same machine also work in IE6, so it's not like the box is unreachable. In fact, my server logs show a 200 status that the page was reached.

If it matters, I'm running WordPress for the site, so I think it could be a PHP thing at this point. However, my other WordPress site on the same box (which is Debian Lenny, btw) loads just fine. So weird.

Many thanks for any help.

UPDATE: Just replaced home page with static HTML and it loaded. Looks like it could a PHP issue. Is it possible there is some difference in how IE6 acts with PHP as opposed to other IE versions?

UPDATE 2: I'm on WP 2.9.1 and have disabled all of my plugins. Interestingly, I see the title of the site for a brief time for the error pops up. Does that pretty much confirm that it's PHP related? I'm using PHP 5 if that matters.

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

Issue fixed. Problem is that you cannot write to the HEAD HTML element before it is closed, caused by my moving my asynchronous Google Analytics script there.

See http://support.microsoft.com/kb/927917

share|improve this answer
    
There's a discussion on the IE Blog about how this was partially fixed in IE8 blogs.msdn.com/ie/archive/2008/04/23/… –  scunliffe Jan 22 '10 at 15:01
add comment

Check proxy settings of IE6, it may be using some random proxy.

Also, it goes without saying, you should probably move away from IE6, offer a JS pop up that alerts the user to upgrade their browser.

share|improve this answer
    
Hmm, nothing on the proxy front. Thanks, though. Realistically I'd love to just deny my users outright (got my wish I guess), but I'd rather do it on purpose ;). –  Eric Wendelin Jan 8 '10 at 19:44
    
can you access any other sites in 6? What about your webserver logs, do they show unusal issues? What technology is the site built in, if it's a dynamic language (Ruby, PHP, .NET, etc) you should be able to get some verbosity in the output and write it to a log to see why it's failing. –  WedTM Jan 8 '10 at 19:56
    
That's the odd thing. The access log shows a 200 OK and nothing in the error log. The site is built in PHP (Wordpress). I'll turn up my log level to DEBUG and see if that helps. –  Eric Wendelin Jan 8 '10 at 20:00
    
PHP shouldn't matter to IE6 as a language. PHP simply outputs rendered HTML to the browser. HOWEVER!!! It may be sending a location header ("header("Location:<some other place>");) that is incorrect, causing IE6 to route somewhere it doesn't like. This would usually manifest itself in the other browsers as well though. Do you have a URL that we can look at and examine? –  WedTM Jan 8 '10 at 20:25
    
Turns out I was an idiot and the problem was Javascript. I appreciate your dialog though :) Thank you. –  Eric Wendelin Jan 9 '10 at 4:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.