Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We've got a bunch of remote admin scripts which rely on psexec and they do not appear to be working over the network on our new 2008 hosts. An error dump is below:

C:\Users\<user>\Desktop\PsTools> psexec \\<host IP> -u Administrator -p <pass> <cmd>
PsExec v1.97 - Execute processes remotely
Copyright (C) 2001-2009 Mark Russinovich
Sysinternals - www.sysinternals.com
Couldn't access <host IP>:
The network name cannot be found.
Make sure that the default admin$ share is enabled on <host IP>.

We've tried both the machine name and the IP address in with the same results. The same command has worked previously with our Win2K3 hosts - so we're presuming it is some form of security change between the 2003 and 2008R2.

Anyone have any clues?

share|improve this question

3 Answers 3

There are some Inbound Connection rules of the Windows Server firewall you'll have to enable for File and Printer Sharing:

  • Echo Request
    • ICMpv4-In
    • ICMpv6-In
  • NB-Datagram-In
  • NB-Name-In
  • NB-Session-In
share|improve this answer

I had this problem today, and here is how I fixed it. Thanks to reading the description of how psExec works.

Open Services on the remote machine. Check that 'Server' service is enabled and started. psExec will not work if 'Server' is not running.

share|improve this answer

Windows Vista/2008 changed up the security settings (win 7/server 2008R2 by extension)

Verify that File and printer sharing is enabled and allowed through the windows firewall. On Server 2008 and Server 2008 R2 they are turned off by default. In server 2003 it was enabled by default and was accessible.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.