Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to add streamlined parallel HTTP requests for my site, from what I read here:

http://ajaxian.com/archives/using-cnames-to-get-around-browser-connection-limits

However, I can't seem to get it to work.

I want: http://dynamic0.vilegaming.com/layout/include/terran-img/h3.jpg

To point to: http://vilegaming.com/layout/include/terran-img/h3.jpg

Here's what I have in my DNS..

dynamic0 CNAME vilegaming.com. 
dynamic1 CNAME 67.222.12.238 
dynamic2 CNAME ns1.vilegaming.com.

(0 and 2 point to the default Apache "working" page, and 1 says the site doesn't load.)

And in my httpd.conf..

<VirtualHost *:80>
   ServerName vilegaming.com
   ServerAlias *.vilegaming.com
</VirtualHost>
share|improve this question
    
I hope your httpd.conf has more in it than that. Can you post the full virtual host config please? –  rodjek Jan 10 '10 at 21:27
    
Here's all the VirtualHost lines: pastebin.com/f518d14a7 –  Kris Sauquillo Jan 10 '10 at 21:42
    
Why all the - votes for the question? All the information has been provided, it's clear english and well asked... –  Mark Henderson Jan 10 '10 at 21:50

2 Answers 2

Try changing dynamic1 to an A record instead of a CNAME.

share|improve this answer
    
Thanks, that worked for somewhat fixing it. Now it points to the Apache page like the other subdomains. –  Kris Sauquillo Jan 10 '10 at 21:20
1  
Another option is to change 67.222.12.238 to just . - as it is now it's looking for 67.222.12.238.vilegaming.com, putting it to just . will "copy" the A record from vilegaming.com –  Mark Henderson Jan 10 '10 at 21:49
    
@Farseeker - no a CNAME value of '.' will not make it a copy of the previous record. –  Alnitak Jan 11 '10 at 10:50

CNAME needs to point to a hostname, not a nameserver and not an ip address. So that explains why your entry for dynamic1 wasn't working.

As for why the other two entries aren't working, that's an Apache issue. Vilegaming.com isn't set up in the config file you pointed to, at least not properly. You need to find where it is set up and add the ServerAlias entry there. Note that www.vilegaming.com also doesn't work, so you also need to add that in as a ServerAlias. Try grepping /etc/apache2 for vilegaming.com to find out where it is configured.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.