Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In our domain I have a Windows Server 2008 R2 machine "GWY" with the Network Policy and Access Services role installed. From this machine I can open the Network Policy Server management console to administer this role.

However, I have another Server 2008 R2 machine "WKS" in the domain where we have all the management consoles installed so we can manage all the servers from one location. I cannot find how to access the Network Policy Server console on this machine though.

share|improve this question

The Remote Server Administration Tools for Windows Server 2008 R2 do not include the MMC snap-in for managing the Network Policy Server; the snap-in is installed only on servers where the NPS role is actually enabled.

From a server which has the NPS role enabled, you can run mmc.exe, add the NPS snap-in to it and have it connect to a remote server; but you can't do the same from a computer which has only the RSAT package but not the NPS role.

share|improve this answer

After you install NPS, you can administer NPS servers:

  • Locally, by using the NPS Microsoft Management Console (MMC) snap-in, the static NPS console in Administrative Tools, or the network shell (Netsh) commands for NPS.
  • From a remote NPS server, by using the NPS MMC snap-in, the Netsh commands for NPS, or Remote Desktop Connection.
  • From a remote workstation, by using Remote Desktop Connection.
share|improve this answer
Sure, I understand this, but how do I locate the NPS MMC snap-in on a server that is not running NPS itself. The "Remote Server Administration Tools" Feature doesn't appear to include this even though it suggests it does with the "Network Policy and Access Services Tools" sub-feature. – Jason Stangroome Jan 11 '10 at 23:45
You can't locate it, because it just isn't there, sorry :-( – Massimo Feb 17 '12 at 12:43

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.