Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I want to print from a Debian (Lenny) workstation to a Windows networked printer. I'm not even sure what type of Windows network this is. Our tech-support is friendly but doesn't want to get involved with supporting Linux. I need to use it for a variety of reasons and am completely stumped because I know nothing about Windows networking.

They gave me URI smb://msprint.ourorg.edu as the "address" of the printer and further confirmed that the domain is "OURORG" and the share is "PHYS-PRI". I've installed CUPS and made sure that it's running as a daemon, I've clicked on the system-config-printer[1] icon, selected the printer as a Windows printer shared via SAMBA and entered the above URI. Attempting to print a testpage just sees it sit in the queue.

I attempted to see if I could access the share using two other methods.

Method 1. First I tried the "smbclient" from the CLI:

$ smbclient -L //msprint.ourorg.edu -U user23
timeout connecting to 192.168.44.3:445
timeout connecting to 192.168.44.3:139
Connection to msprint.ourorg.edu failed (Error NT_STATUS_ACCESS_DENIED)

Method 2. I tried to use the GUI tool Smb4K.

This shows me four other toplevel (I'm assuming they're domains?) groupings one of which is the one which our IT department supplied to me. Clicking them shows a bunch of other machines with (what I assume are NetBIOS names?) including my own. I see all sorts of other networked printers belonging to other departments but none within mine. Certainly not the PHYS-PRI one suggested to me by the IT folks.

I realize that I'm probably using the wrong terminology for the windows network, but can anyone help me with this? What steps should I be taking in debugging this? Do I need to actually run my machine as a SAMBA server to authenticate to the printer or should I just be able to communicate using CUPS?

  1. It's a GUI to CUPS configuration http://cyberelk.net/tim/software/system-config-printer/
share|improve this question

4 Answers 4

You used the wrong syntax with smbclient:

  • Either use smbclient -L msprint.ourorg.edu -U user23 (to *L*ist all shares on server msprint.ourorg.edu
  • Or use smbclient -L \\msprint.ourorg.edu\share_name -U user23 (to display content of share *'share_name'* on server *msprint.ourorg.edu
share|improve this answer

In the CUPS config you need to add the user and password, like this:

smb://user:password@msprint.ourorg.edu/PHYS-PR

share|improve this answer

It should just work. By Windows network printer you mean a printer shared off a windows machine? I suspect either you got the wrong printer queue name or you don't have permissions to print. Try from a windows machine and see if you can find the printer queue the admin gave you.

share|improve this answer
    
Q: "By Windows network printer you mean a printer shared off a windows machine?" A: All I know is that it's somewhere on our internal network and everyone else uses Windows (apparently w/out problems). They don't want to give me the actual IP address b/c of wanting to be able to bill our department. Q: "Try from a windows machine and see if you can find the printer queue the admin gave you." A: Will do that when I bring in a colleagues WinXP laptop tomorrow. I've also been poking around manpages and will try a "smbclient -L <username> -d4" for more details. Thanks for the suggestions. –  user31383 Jan 11 '10 at 20:26

The printer queue name should come after the URI. When I send from Mac to a windows print server I send it as smb://server.ad.myorg.edu/queuename and then use authentication.

You may be able to use the GUI that comes with cups. http://localhost:631/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.