Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a VoIP service running perfectly for outgoing calls but I cannot receive incoming calls.

I have a Netgear DGN 2000 modem router on and a Lynksys Phone Adapter PAP2 on

I have created 3 new custom services: Service Table Service Name Ports tlenfon(TCP) 5060 tlenfon2(UDP) 15000 tlenfon3(UDP) 35000

I have reserved the address for the PAP 2

I have forwarded the ports for each service to the PAP2 Service Name Action LAN Server IP address WAN Users Log tlenfon ALLOW always Any Always tlenfon2 ALLOW always Any Always tlenfon3 ALLOW always Any Always

I have checked the Default DMZ and specified

What have I missed?

share|improve this question

Not receiving incoming calls means that the service on the other end cannot reach through your NAT router. This is likely caused by an improper port redirection, the PAP is advertising itself using the wrong IP address, or something similar.

Now, SIP speaks often on UDP port 5060, not TCP, so perhaps adding that to the list of forwarded ports? Also is this a multi-line device? If so, 5060 may only be one port you need to forward.

Try contacting your VoIP provider and ask them for assistance. If it's a home-grown one, speaking to something like Asterisk, then at least it will be easier to debug.

share|improve this answer
Thanks. I have checked that all the right ports are forwarded. My next step is to try to get the remote end to run a debugger. Pity they dont speak English :-( – David Brown Jan 12 '10 at 23:45

Did your provider instruct you to do the port forwarding? Some VoIP services use their own methods for NAT traversal and may not need forwarded ports at all.

According to the Netgear manual, the "Default DMZ server" gets all the traffic that would normally be discarded - not sure if this what you want and need, it depends on your VoIP provider.

Have you tried disabling the SIP ALG (same page where you set up the Default DMZ)?

Was the Linksys PAP preconfigured by your VoIP provider or did you set it up yourself?

If you are comfortable with sniffing your network, you could plug an old hub into the modem's ethernet port and connect the Linksys PAP and your PC to the hub, then run Wireshark on the PC to see if your incoming VoIP traffic makes it past the router.

share|improve this answer

Sounds like a firewall problem related with NAT. If you can, go into your PAP2 and look for the NAT Keep Alive Intvl. Check that value and lower it down to 15 or even 5 seconds. That will have your PAP2 send a keep alive type of message to your router to keep the NAT ports open for you.

share|improve this answer

Which VOIP system are You using ? I had similar problem with Elastix/Asterisk/FreePBX BOX. After edditing NAT settings at:

UnembedFreePBX / Tools / Asterisk SIP Settings i get worked

Try playing with this

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.