Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I changed the service account used for MSSQLSERVER from Local System to a domain user account (domain\sql server)

When connecting to SSMS from my workstation, it came up with an error:

Cannot Generate SSPI Context - SQL Server 2008

If i connected using the SA account, I could get in, however, if I tried to save changes to my Maintenance Plan, it came up with the same error. (I'm sure there would be other operations that cause this error, I just used this as an example)

I also noticed I couldn't start SQL Server browser - Pops up error message:

the service cannote be started, either because it is disabled or because it has no enabled devices associated with it. [0x80070422]

I am using SQL Server 2008 Standard and Windows 2008, in case that is important....

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Does your domain user have access to the folder where the physical files are stored?

share|improve this answer
    
no, but they do now... and it works! thanks –  alex Jan 15 '10 at 20:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.