Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a DIR-665 (Dlink) router that I want to forward VPN via PPTP as well as L2TP to my OS X server. The VPN server is setup correctly, I can connect locally. The router has Virtual Server setup to point port 1701 requests to the proper servers static IP.

The issue is that as the server connects from an external network it simply hangs for a few seconds then faults. I've checked the Firewall settings on the router and it seems to be allowing VPN connections through.

At this point I'm at a complete loss and have no idea. :-(

Hopefully someone has experiences a similar situation.

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

Check that you have GRE forwarded - it kind of uses port 47. This is the normal stumbling block for VPNs and home routers.


Edit

To (badly) summarise: port forwarding forwards TCP and/or UDP packets which are on layer 4. GRE is kind of between layer 3 and 4 (again Wikipedia has the explanations) so whilst it kind of uses port 47 it isn't a typical TCP or UDP packet and hence not all routers will forward it.

That's what you need to check - many routers specifically have the function that specifically forwards GRE.

Perhaps somebody else could put it a bit more eloquently than me!

share|improve this answer
    
Hi Jon! Thanks for the recommendation. I've setup two virtual servers on my router now. One to point 1701 to the os x server and another to point port 47 to it. When I attempt connecting I still get the "The L2TP-VPN server has not responded" message. Any other ideas? –  Dave Jan 14 '10 at 17:47
    
Check to see if you can forward GRE rather than port 47 - it's not quite the same thing. –  Jon Rhoades Jan 14 '10 at 22:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.