Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

how should I set the shm* values in Mac Os X 10.5.6 Leopard in a persistent manner?

share|improve this question
    
sorry, actually this works. I just had a typo and edited the wrong file syslog.conf... –  Alex. S. May 20 '09 at 5:22
    
I changed the original wording, and put the solution as answer (only to help somebody else) –  Alex. S. May 20 '09 at 5:26

3 Answers 3

up vote 8 down vote accepted

put this

kern.sysv.shmmax=524288000
kern.sysv.shmmin=1
kern.sysv.shmmni=64
kern.sysv.shmseg=16
kern.sysv.semmns=130
kern.sysv.shmall=131072000
kern.sysv.maxproc=2048
kern.maxprocperuid=512

on this file /etc/sysctl.conf

and then reboot.

to verify run this command

 sysctl kern.sysv.shmmax

and it should give 524288000

share|improve this answer

(from: http://willbryant.net/software/mac_os_x/postgres_initdb_fatal_shared_memory_error_on_leopard)

One wat to fix it is to run:

sudo sysctl -w kern.sysv.shmall=65536
sudo sysctl -w kern.sysv.shmmax=16777216

and then run the initdb command. To persist the changes you need to edit/create the file /etc/sysctl.conf with this:

kern.sysv.shmall=65536
kern.sysv.shmmax=16777216
share|improve this answer

What do you get when you run 'sysctl -p' ? does it load your settings from /etc/sysctl.conf? What file is listed as default when you do 'sysctl --help' ?

share|improve this answer
    
thanks for your response, I just wrote the wrong command to edit the wrong file. /etc/sysctl.conf works as expected. –  Alex. S. May 20 '09 at 5:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.