Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.
  • I have a SBS2003 runing Exchange Server 2003 SP2.

  • My OWA has a godaddy certificate valid for 3 years to come installed. HTTPS works fine for OWA.

  • The certificate has also been copied into the Nokia E95

  • I am trying to syncronize my Nokia E75 via Mail for Exchange to my mail account on the Exchange server.

These are the steps i use:

  • Menu > Email > New > Start > Select Internet Gateway > Than i enter the details: myemail@mydomain.com I select company email > Mail for Exchange > In the domain menu i enter : mydomain In the username/password menu i enter : myusername/mypassword In the server menu i enter : mail.mydomain.com (where the DNS resolves into the server's IP address) In the secure access i select : Internet / Secure / 443
  • NOTE : port 443 has been opened on my SBOX and forwarded to the exchange server.

  • On IIS > default website > properties > directory security > secure communications > edit > the "Require Secure Channel SSL" is enabled.

However, when i try to sync my phone i get the following error code: * Mail for Exch permissions illegal. Check permission configuration. * The phone log gives the following information : Username or Password Illegal. Correct Username and/or Password in the profile options.

I've tried speaking with the Phone service support but they cannot identify the problem.

Any help will be much apreciated.

share|improve this question

2 Answers 2

While I haven't tried to configure an Exchange Server to allow ActiveSync connections, I have used Nokia devices and Mail For Exchange to sync email, calendar, and contacts to my device.

I would direct you to the Mail For Exchange Manuals, if you don't already have them.

I would also suggest trying the connection from a WiFi node inside your firewall, with a network sniffer attached to the line. Basically, simplify the network arrangement so that you can focus on the application configuration.

share|improve this answer

In the username field try with username@domainname where domainname is the AD domain where the user is validated

share|improve this answer
    
Hi, First thank you for your response. I've tried the following in the username field: username@domain domain@username username\domain domain\username I get the same error for all of them. Also worth mentioning - on my SBOX logs i see the IP of the phone connecting via port 443. –  Sebastian Jan 14 '10 at 15:31
    
Okay here's a change. I temporary disabled my SSL on OWA / Phone. and the syncronization works fine. Aparently it is something related to the SSL option. –  Sebastian Jan 14 '10 at 15:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.