Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I download a file from our companies Linux FTP server it keeps adding extra line breaks to the file, so that the file is double spaced in a normal Windows editor.

I tried opening it in gvim for windows and this warrants a line-break as well as a "^M" at the end of every line, but does not insert the additional line character.

I realize this is probably a \n\r problem between Windows and Linux (I really thought that Windows didn't have issues reading \n\r's but I guess I was wrong). I was just wondering if there was anyway I can configure my ftp client (filezilla) so that it removes these extra characters ("^M").

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

Try setting the default transfer type to Binary. If that doesn't work try setting it to Auto or ASCII.

share|improve this answer
    
Yup that did the trick Joe! +1 Thanks! –  leeand00 Jan 14 '10 at 16:24
    
Glad to help... –  joeqwerty Jan 14 '10 at 16:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.