Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Do you have some recommendations on setting up a MANET using Debian based OS? I read some documentation after some web digging and I found that a basic setup would be creating an ad-hoc wireless network and some routing algorithms (implementation) as:

  • OLSR (Optimized Link State Routing protocol):
  • OSPF (Open Shortest Path First Routing)
  • B.A.T.M.A.N. (Better Approach To Mobile Adhoc Networking)
  • AODV (Ad hoc On-Demand Distance Vector)

I'm currently starting to test some of them (currently B.A.T.M.A.N :D) but haven't finish any of them. I got really inspired after seeing open-mesh.com project/products (it looks like they use ROBIN and B.A.T.M.A.N).

Thanks in advance!

Note: I'm a complete newbie at this so I apologize if some terms/concepts aren't correct. All feedback will be appreciated

share|improve this question

3 Answers 3

You also need to look at 802.11s mesh mode and OSPF-MDR from here: http://www.manet-routing.org/

The Boeing Quagga patches are perhaps the easiest to use and most flexible system, since you can route both IPv4 and IPv6, and extend OSPF to non-wireless parts of the network, using only one routing daemon and protocol.

share|improve this answer
    
Thanks Andrew. OSPF-MDR sounds very interesting. I'll give it a try. Best regards –  Humber Jan 19 '10 at 12:08

Check out CoCoCorp.com

share|improve this answer
    
Thanks John. CoCoCorp looks like a mature commercial product but I am looking for open source free alternatives to create the MANET. Although, is very interesting :) –  Humber Jan 19 '10 at 12:11

Stumbled on your question when looking for olsr. I did something with ubuntu and olsrd to create an ad-hoc network. I used three (didn't have more) ubuntu PC's (one as a gateway) and 1 Linksys WAP54G (with freifunk firmware).

It all worked pretty easy except for the fact that getting the right "Cell-ID" was somewhat unpredictable on ubuntu. I got it all worked out here: http://www.kwalinux.nl/what-a-mesh/1129/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.