Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have just bought a Belkin Flip 2 port KVM. Functionally it is almost there except I have a keyboard sticking problem. So if I type the word 'Hello' it will often (about 25% of the time) output 'Hellooooooooooooooooooooo'. If I plug the keyboard directly into the USB on the computer I don't have this problem, only when plugged into the KVM. I feel like it is a USB speed problem.

Followup It appears I have the same problem with the mouse, it will jump from one side of the screen to the other as I move it. The mouse is annoying but half as much as the keyboard.

share|improve this question
    
What OS are you using this KVM on? –  Sangai May 20 '09 at 10:57
    
Windows Server 2008. –  Craig May 20 '09 at 10:58
    
Are you plugging it into 2 machines or just 1? Is the problem occurring on both machines? –  Sangai May 20 '09 at 11:07
    
It is plugged into two PC's, one desktop and one laptop. I have the problem on the laptop but not the desktop. –  Craig May 20 '09 at 11:26
add comment

1 Answer 1

First thing I would check is the power management on the USB's in Device Manager. Make sure this is turned off.

Also, have a look to see if there are any new drivers for the USB available from the manufacturer. I've seen this kind of problem before on XP and updating to the latest 2.0 drivers has resolved it.

Another thing to try would be to swap the cables from the KVM to make sure it's not a problem with the Belkin as well. As all is working in the desktop but not the laptop it could very well just be some duff cables.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.