Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a bit of an issue that is just frustrating me.

When I turn my notebook on with the network cable plugged in, the link lights above the port flash happily, until windows starts up. As soon as windows starts up the lights simlpy turn off and windows reports that the cable is unplugged.

More interestingly, if I go to device manager and disable the Local Area Connection, the lights start flashing again, but when I enable it, the lights stop.

We have tried re-installing drivers, different network cables etc. We have also confirmed that the network cables work by plugging them into different machines / devices (IP Phone).

This seems to be happening in one building of our company where I am now. When I plug my machine back into the network at my normal desk, it works fine.

The Administrators assure me that they do not do anything on the switches and the like that would stop me from connecting to the network from any available port.

Could this be a policy setting? I've tried turning off the ability for windows to power down the device when it's not in use, with no effect.

Any ideas would be welcome.

Thanks

Gineer

share|improve this question
    
Is this a Dell laptop? –  JoeOD Jan 15 '10 at 10:32

1 Answer 1

up vote 2 down vote accepted

Two quickies,

  • what about speed? is your card a gigabit ethernet? is the switch where it's connected to forcing a certain speed without duplex negotiation?
  • have you tried running a live linux distro? This might help ruling out any hardware or location issue
share|improve this answer
    
Solution: Device manager -> Properties (for the network card) -> Advanced tab: The "Link Speed & Duplex" property was set to "1Gbps Full Duplex". I changed that to "Auto Negotiation" and everything started working. Basically, it just means the network I am connecting to now is fairly crappy. –  Gineer Jan 15 '10 at 10:37
    
you're welcome :) –  lorenzog Jan 15 '10 at 12:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.