Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have just installed Webmin on an Arch Linux distro, but I can access it only on the box itself: https://localhost:10000. When I try it from my work computer it doesn't work. I added "allow=127.0.0.1 my.i.p.here" in /etc/webmin/miniserv.conf but it is of no use. How can I make it work?

share|improve this question

3 Answers 3

IF it's like my linux box, sitting behind a huge firewall in the office I actually disabled the firewall on the linux box itself as this server is never going to have public acces. Possible idea if you are in a similar situation.

Alternatively, I beleive you can use this command to allow port 10000 access:

iptables -I INPUT 1 -p tcp --dport 10000 -j ACCEPT

That is how I got webmin working before I decided to disable the firewall.

share|improve this answer
  1. Make sure you restart webmin after any changes
  2. If you have enabled firwall make sure you add a rule to access the webmin port.
share|improve this answer

Check-list :

  1. webmin works locally,
  2. the webmin server listens from remote addresses,
  3. the remote host can listen port 10000 on the webmin server's host,

1 and 2 seem OK, you checked 3?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.