Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Apologies if I'm asking an already asked question, but have searched and can't find any similar to this, so here goes.

I have RHEL5 running Apache 2.2.3 (prefork) with MySQL and PHP. Up until a couple of days ago I was running MySQL 5.0.2, I mistakenly applied yum updates, which in turn gave me MySQL 5.0.77. Ever since then, I've had a nightmare! The software I use behind Apache is bespoke, but requires MySQL and PHP. It is basically a web server written in PHP with a MySQL backend. It is verified as being ok with Apache 2.2.9; MySQL 5.0.5 and PHP 5.2.6 running on Debian Lenny.

At the moment my server is RHEL5 with Apache 2.2.3; MySQL 5.0.77; PHP 5.2.6.

Would I be right in thinking I need to upgrade my Apache to 2.2.9 to prevent errors such as this one when I try to start httpd "/root/php-5.2.9/libs/libphp5.so: undefined symbol: zend_wrong_param_count"

If I ./configure with PHP5.1.6 I can get httpd to start, however I get loads of MySQL errors and not much of my web server works correctly.

A stumbling block for me is RHEL, I'm more used to DebianGNU linux as opposed to Redhat.

If anyone could help I would be really happy, thanks.

share|improve this question
    
I am also wondering if I need to make clean Apache and MySQL before I re-make my PHP insall? Basically I ran yum update, this gave me MySQL5.0.77. I am thinking maybe if I install Apache 2.2.9 this will work better with MySQL5.0.77 and PHP 5.2.9? My server is currently displaying MySQL errors when I access it via http. If I change my PHP up to 5.2.9 I can't get httpd to start so have dropped back to PHP5.1.6. –  Mark Jan 18 '10 at 9:43
add comment

1 Answer

up vote 0 down vote accepted

I can't answer your question specifically, however how you made sure you've run the command "mysql-upgrade". When I've upgraded MySQL on centos/rhel boxes in the past, after installing the packages I've needed to run this command (which may actually be "mysql-update" or similar, I'm writting this from memory), which goes through all your databases to make sure they are compatible with the new underlying version of MySQL.

share|improve this answer
    
Thanks, if I connect to MySQL it does tell me that it's mysql 5.0.77, would I still need to update the actual database too? –  Mark Jan 18 '10 at 9:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.