Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have an IBM x345 server running raid-1 with 2 drives that went defunct after a reboot. ServeRaid has an x by both drives (36g scsi) marked defunct. The option to rebuild the defunct drives under ServeRaid is not there. Is there any way I can get my data back from this? Any help appreciated. Thank you.

share|improve this question
3  
Go to your backups. –  LukeR Jan 18 '10 at 5:47
    
yeah, it turns out that the guy that was supposed to be doing the backups was not doing his job. anyways, he's in a deep hole right now. I have tried to put this same config into another server but windows 2003 server doesn't see the drives correctly. Win 2003 disk management sees the drives as "unknown - unreadable" as seperate drives and not 1 mirror volume. I have read about this problem on NT4 somewhere but can seem to find the resolution to it. Again, any help is much appreciated. Thank you. –  user32035 Jan 18 '10 at 6:37

4 Answers 4

what you can do is try to reinit the raid

  1. power down host, remove both drives
  2. power host up, go into raid controller setup and reset the config (the drives should be out, remember?)
  3. power host down again, insert the two drives
  4. power host up, go into raid controller bios, and create a new raid1 on the two drives, make sure you don't mix up their order, and very important - DO NOT LET THE NEW RAID INITIALISE - it will erase the disks
  5. if you know which drive failed first, force it offline, if not, try the procedure, forcing offline each of the drives and trying to boot using the other in a degraded raid array

This should bring you to a host with one disk online, and the other offline, making the raid1 degraded, but usable enough to boot and back up the data

share|improve this answer
    
dyasny, thank you for your tip. I can not boot because the mbr is messed up. the initial proglem was system hang, reboot and got corrupted mbr. reboot to try to do a system repair and got no disk found. that's when I found out both drives were defunct when I got into raid management. from that, do you think i can still repair the raid-1 (mirror) confige even if both drives are defunct? thanks again, any help is grately appreciated! –  user32035 Jan 18 '10 at 18:36
    
ok, i just tried to reset raid-1 like you said but after shut down, removing the drives, reboot, reset controller config, shut down, reinstall drives and reboot, i still get defunct drives in raid config. it's not the controller because I am able to put 2 new drives in and configure raid-1 on it just fine. just my luck, how can i have both drives on a mirror go down at the same time. there's got to be something else wrong here that i'm not seeing. i can hear the drives spin up, raid controller list it but it can't access the drives... –  user32035 Jan 18 '10 at 20:19
    
controller or drive firmware might be to blame –  dyasny Mar 18 '10 at 14:35

Time for a data recovery service like OnTrack. You definitely won't have any luck putting drives that were in a hardware RAID-1 into a computer and try to software-RAID them, that will not work, period.

share|improve this answer

Try to use advanced options and "read configuration from drive to controller" in controller bios.

share|improve this answer

If you think it is just a bad MBR that is stopping the boot then try a CD boot using a Linux Live CD or a BartPE CD (yes, it's a lot of work to build it but it has helped me out multiple times since I built the first one). It will boot from CD and run from a RAM disk. If your hard drives are available but unbootable you will be able to browse them and start recovering your data.

Or can you install the controller card and two disks into another server that already boots?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.