Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have installed Dell Openmanage Server Agent 4.2.2 on Windows Server 2008. I need the newer version, so I need to install this version first. However, outside some registry references pointing to sources that aren't there, there is little or no trace of it being installed. For example, no trace of the program files or an entry in Prgrams And Features. Still, installing a newer version keeps coming up with an older version that needs to be removed first. When I try to install version 4.2.2 to repair and eventually remove it, it gives an error:

Dell Openmanage Server Agent - Error

An error was encountered while testing machine type. Failure openingen required handle to .DLL. Dell Openmanage Server Agent cannot continue the installation. Setup will exit now.

I haven't found anything using different parts of the error messages as search terms.

share|improve this question

1 Answer 1

Look for a tool called OMClean which should help you remove all of the assorted "extras" from the uninstall process. I'm pretty sure its part of the Openmanage installation cd.

share|improve this answer
    
I found it. When I run it, it seems to work but afterwards nothing changed, at least not effectively. –  Erwin Blonk Jan 19 '10 at 11:14
    
OMclean logfiles gives no error, says everything is sets out to remove, is removed. –  Erwin Blonk Jan 19 '10 at 11:32
    
Have you tried re-installing the originally installed version, to get a "clean" install, then uninstalling? Is it possible the original installation didn't go properly? Can you confirm you have installed any prerequisites? –  Mitch Jan 19 '10 at 19:39
    
Re-installing the original (v4.2.2) immediately gives the error I mentioned, which points to a dll that is only identified as .DLL. Newer versions have uninstalling it as a prerequisite. Looking through the registery hasn't helped any. –  Erwin Blonk Jan 21 '10 at 12:35
1  
Check the Dell OM forums. What you're seeing is definitely odd but the Dell people might have see this before. –  Mitch Jan 21 '10 at 16:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.