Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've been connecting to my web server with active mode in FileZilla with no problems. Over the weekend, an SSL certificate was dropped into a folder that I access with FTP, and which contains files for the website. Now I am receiving a 425 error in active mode on the FTP root, so I can't really do anything but log in. In passive mode, I can connect and move around in the directory tree, but the connection seems shaky. Occasionally I'll time out, and I can't get access at all to the folder containing the SSL certificate.

My question is how does the SSL certificate affect my FTP connection (if at all)? Does its presence demand the use of FTP over SSL?

Note: As far as I know, the only change which occurred was the placement of the SSL certificate. Firewall settings, FTP client and server settings should all be the same as before, when everything was working.

share|improve this question

2 Answers 2

The mere presence of a cert isn't going to affect connections to the server at all, it's just another file from the server's perspective. Now, if that cert was installed and the server set to use SSL then that'd be a different story but I'm not gathering that from your description of the problem. The most likely thing is that something actually did change that disabled the use of active ftp. Can you confirm that there actually were no changes made to the firewall?

share|improve this answer
1  
Sorry, I didn't make that clear. The SSL cert was actually installed and is being used. It's a temporary one. Unless the actual installation of the cert changed firewall settings (which it shouldn't, I don't think), I can confirm firewall settings haven't changed. I'm seeing the usual port 21 and port 20 for FTP are configured to allow access. I know in active mode, the server makes a data connection to the port the client provides, which is variable. Is there a specific way to configure the firewall to account for that? –  Chris Jan 18 '10 at 16:11
    
Hm, I just tried to connect to our other server with the same results, so it's apparently not a server config issue. I know for a fact that server hasn't changed in a while. –  Chris Jan 18 '10 at 16:30

Problem solved. It had nothing to do with config. I restarted the computer and now it works. I'm chalking this one up to Windows. Thanks for your help, squillman.

share|improve this answer
1  
Excellent, glad it's working :) –  squillman Jan 18 '10 at 17:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.