Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am setting up an ubuntu server and want to know what I should be doing on it regularly.

apt-get update/upgrade seems obvious.

Is there a glsa check for example? Anything else I should be running? I guess it depends on what is installed, but I am thinking of the core system for now.

share|improve this question
add comment

migrated from stackoverflow.com Jan 18 '10 at 16:36

This question came from our site for professional and enthusiast programmers.

5 Answers

up vote 17 down vote accepted

Upgrading packages as you mentioned is the most important thing. A couple of tools that can make that easier:

  • cron-apt, to notify you by email when there are upgrades to install; and
  • unattended-upgrades, to automatically apply non-interactive upgrades

Ubuntu also has a security announcement list, but in my experience it is really just a duplicate of the package upgrades that cron-apt will notify you about. On the other hand it will provide a bit more information on what is being fixed (or what is vulnerable) in each security upgrade.

share|improve this answer
add comment

I installed munin on my servers so that I can monitor all sorts of things about them, including whether apt thinks there are packages to install.

share|improve this answer
add comment

If you want to just do the updates create a text file with:

apt-get -yq update
apt-get -yq upgrade

and add it to crontab for whatever timeline you want.

share|improve this answer
    
Doing this will also likely clobber any configuration file changes you may have made –  Martin OConnor Feb 10 '09 at 17:36
    
Although I suppose that could be a problem in some cases I have yet to experience it myself i have 4 Local Debian servers and 4 Remote (Datacenter servers) ones also running Debian and I've been using debian as my only server OS for a few years. –  Unkwntech Feb 11 '09 at 20:02
    
Forcing "yes" (-y) is awfully dangerous. –  bortzmeyer Feb 12 '09 at 9:55
    
I "could" be but as I said above this has yet to fail me. –  Unkwntech Feb 12 '09 at 10:42
add comment
apt-get moo

try it :)

share|improve this answer
add comment

I put the following line in /etc/crontab

2 */2 * * * root    apt-get -qq update && apt-get -qq -y --force-yes upgrade && apt-get -qq clean

Beware that it does not install new packages, therefore it might miss some kernel updates: you still have to run synaptic/aptitude once in a while.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.