Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to remotely access MS SQL Server Express 2008.

  • I have turned on service "SQL Server Browser"
  • I have turned on service "SQL Server (SQLExpress)"
  • I have enabled TCP/IP and set dynamic ports to blank and tcp port to 1433 in properties
  • I can connect localy(using ip) so my credentials are correct.
  • I have a exceptions record in my windows firewall setting port 1433 as open.
  • I have performed a system reboot making all services are still turned on.

After i try and connect via a remote computer I get this error.

Cannot connect to XXX.XXX.XXX.XX
============================

A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) (.Net SqlClient Data Provider)
-----------------------------------------------
Error Number: 3
Severity: 20
State: 0

Your ideas and solutions will be greatly appreciated.

KJ

EDIT Hi and thanks for the quick responses. At present there is no connection string. I am trying to connect using: SQL Server Management Studio 2008

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

Have you switched on "Allow Remote Connections" under the Properties Page->Connections when you right click on the server in Management Studio. Also, make sure that on both the server and client that you make TCP/IP the default protocol.

share|improve this answer
    
Yeap that option was turned on. I cannot see an option to make tcp the default protocol. –  Kieran Jan 19 '10 at 23:21
    
On your client, in SQL Server Configuration Manager, under the Native Client Configuration, there is an option for Client Protocols and a way to specify the order. –  SqlACID Jan 20 '10 at 3:09
    
It was set 1. Shared memory. 2. Tcp/ip... I turned off shared memory and still have not been able to access it. –  Kieran Jan 20 '10 at 23:13
    
There was an external hardware firewall which i did not know about. argh. Thanks very much for your help. –  Kieran Jan 21 '10 at 4:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.