Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have question. I'm using ESXi 4.0U1 in an IBM x3200M2 with an integrated LSI 1064e RAID controller, without any kind of cache. I have 3 250GB HOT-SWAP SATA HDs configured in RAID1E (IME). ESXi works fine, read speed are quite OK, but write speeds are incredible slow, never more than 8MB/s, and this is the best case scenario, benchmarking with iozone streaming writes, using a VMWare Paravirtual controller and with only this VM active, no swapping of any kind (total vm memory reserved). Already wrote to IBM but I don't have any kind of pay support so they didn't even answered, so I'm just wondering... anybody has any experience with a similar setup? I just want to be sure this is hardware related and can't be fixed with some kind of config option, because I'm thinking on buying a new RAID controller (Adaptec 2405 looks nice).

Thanks again!

share|improve this question
add comment

1 Answer

What you will generally find is the raid controller has turned off write caching on the HDD as well meaning that you are IO blocked whilst writing to those disks. This is to protect the data being written to the disk is actually written to the disk rather than being stored in a unprotected memory cell.

Whilst 8MB/s is slowish, on 250GB SATA drives (probably 7200 rpm maybe 5400) I wouldn't expect more than that writing, but I would expect about 18MB/s - 20MB/s on reads without a problem.

share|improve this answer
    
If you've got another similar box handy, you can also gauge the raw speed tests before using VMware with SQLIO. It's a free utility from Microsoft. Always, always, always benchmark your storage before you go installing things. sqlserverpedia.com/wiki/SAN_Performance_Tuning_with_SQLIO –  Brent Ozar Jan 23 '10 at 15:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.