Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm getting the following error:

Setup is unable to proceed due to the following error(s):
This product requires ASP.NET v2.0 to be set to 'Allow' in the list of Internet Information Services (IIS) Web Server Extensions. If it is not available in the list, re-install ASP.NEt v2.0

The steps I've taken after a new install of Windows Server 2003:

  • Installed SQl Server 2005
  • Installed .Net Framework 2.0 x64
  • Installed .Net Framework 3.0 x64
  • Verified that ASP.NET v2.0.50727 (32-bit) is set to Allowed in the IIS Web Service Extensions
  • Attempted to install WSS 3.0, failing with the above error

I've tried running the following command to ensure that .Net 2.0 is being used

c:\windows\Microsoft.net\Framework\v2.0.50727\aspnet_regiis.exe -i

Now I'm stuck, can anyone help?

P.S. I've also noticed that I have no ASP.NET tab when I view the properties for the default web site.

share|improve this question

Did you install the 64 bit SQL 2005? SQL 2005 installs .NET 2.0 if it's not already there. I'm wondering if maybe you have a problem with 32 bit and 64 bit both being on the server if you installed the 32 bit SQL 2005.

share|improve this answer
up vote 0 down vote accepted

Found the solution. IIS is required to run in 64bit mode only. It was running in 32/64bit mixed mode. Credit goes to this blog post.

Run the following command in the command prompt to disable mixed-mode:

cscript %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs SET W3SVC/AppPools/Enable32bitAppOnWin64 0

And then re-install .net 2.0 like so:

%SYSTEMROOT%\Microsoft.NET\Framework64\v2.0.50727\aspnet_regiis.exe -i

And verify that ASP.NET v2.0.50727 is set to Allowed in the IIS Web Service Extensions.

share|improve this answer

protected by Iain Aug 21 '11 at 20:55

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?