Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to install rkhunter via yum on CentOS 4.8, but it's just not happening...

Loading "fastestmirror" plugin
Setting up Install Process
Setting up repositories
update                    100% |=========================|  951 B    00:00
rpmforge                  100% |=========================| 1.1 kB    00:00
base                      100% |=========================| 1.1 kB    00:00
addons                    100% |=========================|  951 B    00:00
extras                    100% |=========================| 1.1 kB    00:00
Loading mirror speeds from cached hostfile
Reading repository metadata in from local files
Excluding Packages in global exclude list
Parsing package install arguments
Error: Package tuple ('rkhunter', 'noarch', None, '1.2.9', '2.rh9.rf') could not be found in packagesack

I know some sysadmin basics, but not enough to problem solve when things don't go according to plan, and especially when Google doesn't want to give up the goods! Any help would be fantastic.

share|improve this question

Does yum search rkhunter show anything? Is the yum repository cache up to date? Have you run yum update recently?

Also, Centos 4.8 is very old. I'm not even sure it's still supported.. I wouldn't be surprised if the remote repos for 4.8 had been removed.

share|improve this answer
search returns; [line1] rkhunter.noarch None:1.2.9-2.rh9.rf rpmforge, [line2] rkhunter.noarch None:1.2.9-1.rh9.rf rpmforge. I have no idea what I'm doing when it comes to the cache or yum update (I thought that was a system wide update, not yum itself). Sadly I'm stuck with CentOS 4.8 for now. – MatW Jan 19 '10 at 23:16
Try downloading… and install with rpm. or yum localinstall – Tom O'Connor Jan 19 '10 at 23:19
Just run yum clean all, still no luck... – MatW Jan 19 '10 at 23:31
Have you tried downloading the RPM and installing with localinstall instead? – Tom O'Connor Jan 20 '10 at 10:12

Sometimes the cached data on disk becomes unusable, but yum (thinking it is up to date) does not totally refresh it from the server. My general rule of thumb when running into weird errors like those specified are to clean out the various metadata and caches involved before moving forward, and manually check for updates to yum itself. The second step may be unnecessary, but the first seems to fix most odd repo related errors.

yum clean all
yum update yum


Failing that, your repository definition could be malformed or otherwise damaged. Try disabling the rpmforge repository, and reinstalling it using their instructions.

share|improve this answer
Interesting... "yum update yum" doesn't do anything either: "No Packages marked for Update / Obsoletion". – MatW Jan 20 '10 at 3:17

Excluding Packages in global exclude list

Do you exclude this package ?

You maybe exclude a required package to install rkhunter

share|improve this answer
rkhunter only requires wget, which isn't on the global exclusion list, no. – MatW Jan 19 '10 at 23:12

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.