Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Reporting services on my site always asks for username and password. I want to set it as domain users are never asked for username / password so I'll have a single-sign on. The Reports Application in IIS is set to have Windows Authentication.

Usually the users access the reports by IP address of the Reporting Server :

http://192.168.1.2/Reports

Can someone enumerate the options I should check ?

Thank you

share|improve this question
    
What version of SSRS are you using? –  NYSystemsAnalyst Jan 20 '10 at 13:38
    
The SSRS that's in the MS SQL 2005 pack –  Paul Jan 20 '10 at 14:01

2 Answers 2

up vote 1 down vote accepted

How is Reporting services authenticating to the back-end database? What database type (SQL Server, Oracle, MySQL, etc.) is it connecting to?

If you're connecting to a SQL Server, using the requesting user's credentials, you'll need to setup Kerberos authentication to avoid the "double-hop" issue. This will also involve setting up the appropriate SPNs within AD.

Perform some research, and verify that this is what you wish to do in your environment.

share|improve this answer
    
The connection to the back-end SQL server is done by using a datasource which has user credentials specified. Anyway this user prompting should occur when I'm trying to access the report itself .. I'm still stuck for now at the folder page accessing (IIS settings) –  Paul Jan 20 '10 at 15:00

In the IIS management console, in the properties for the "Reports" virtual directory, on the "Directory Security" tab, click the "Edit..." button for the "Anonymous access and authentication" settings. Ensure that "Integrated Windows Authentication" is the only option checked off.

share|improve this answer
    
having users authenticate by default with IUSR guest account won't do because I have access set up for domain users –  Paul Jan 20 '10 at 14:59
    
Don't use anonymous access, but you need to go to the anonymous access page to enable Windows Authentication for the report manager. Having Windows Authentication enabled on the Report manager allows users to be authenticated using their windows credentials. Those credentials are then used by the report manager to control report authorization. –  NYSystemsAnalyst Jan 20 '10 at 17:44
    
Silly question: Are you on a domain, or are the computers all in a workgroup? –  Evan M. Jan 21 '10 at 0:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.