Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running Apache2.2 and a WAMP stack on XP. I have two XP computers on my home LAN. I have setup a demo website on one of the XP machines (the server machine), and I want to be able to view it on another XP machine (the client machine) - however when I attempt to do so, the browser on the client machine times out after a while and reports that the browser is not available or too busy.

I am able to ping the server machine from the client machine, and receive ACKs (no data lost). I am also able to print documents from the client machine, onto the printer connected to the server machine, so networking is not the issue here.

On the server, I can access the website by typing: http://localhost/thesite.php

On the client, I type a similar url, but with localhost replaced by the IP address of the server machine (same address used in the ping test).

Anyone knows what may be set incorrectly? - I strongly suspect Apache.

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Have you disabled the server's built-in XP firewall -- or at least opened up Port 80 for Apache?

share|improve this answer
    
(I feel foolish for asking) BUT - How do I check either of the things you pointed out?. In the event that they need to be disbled (XP's firewall) or opened port 80 for Apache, how do I do that. I suspect Apache is already listening on port 80, because the httpd.conf virtual host section starts with <VirtualHost *:80> –  user25312 Jan 20 '10 at 15:38
    
Visit the Control Panel. If in "Classic view" open Windows Firewall. Otherwise go to Security Center and scroll down to the bottom to run the Firewall mgmt thingy. If the firewall is on/enabled just hit the Exceptions tab and add one for TCP port 80. –  Chris_K Jan 20 '10 at 15:41
    
Yay! - that worked. many thanks –  user25312 Jan 20 '10 at 15:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.