Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm using Windows Server 2003. I have the FTP services installed, router set to DMZ, and currently Anonymous logins allowed. (I know, security risk, but there's nothing important on there and not worried at the moment)

So here's the thing... I can ftp to my computer, list directory, get files etc, BUT only if I'm using the command prompt. If I try to log in using IE or any FTP client it's just timing out. I've tried: username@ipaddress ipaddress username:password@ipaddress and not able to get any of them to work.

Anyone have any ideas? Thanks!!!

share|improve this question
    
Which FTP clients have you tried and what errors are you getting? –  John Gardeniers Jan 21 '10 at 1:58

2 Answers 2

When you connect to FTP through IE it uses PASV ftp which uses additional ports other than 21. IF your firewall is too strictly configured then IE will have a lot of problems connecting to the FTP site.

share|improve this answer
    
Well, current the router is on DMZ so all ports are wide open. (Hence why I didn't give out my actual IP address). That is what I was thinking too, but I'm not sure if that could be the problem. –  Nick Jan 20 '10 at 18:09
1  
Are you able to test FTP on the local network, just to confirm that the router is not the problem? Also, I know in the past I have experienced this exact symptom and it was related to a local firewall on the computer running the FTP service being too tight. –  einstiien Jan 20 '10 at 18:21
    
I will have to test when I'm back on site. Have about 2 hours before I get to tinker. –  Nick Jan 20 '10 at 19:02
    
Should be easy to test as you can switch Explorer/IE to not use PASV mode in the advanced internet options dialog. –  Oskar Duveborn May 7 '10 at 19:16

If you're using windows xp, most probably it's windows firewall that is blocking connections which the ftp server is trying to connect to. Temporarily disable the windows firewall. or else allow your ftp client full access from the windows firewall.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.