Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm currently working with vista on a domain account with VERY restricted permissions. Every time I'm using a new application which tries to reach the network, my boss has to input his admin password to open the firewall!

I wrote a Java app which needs internet access. I tried to debug it. Windows asked for the admin password. My boss was busy that time and a had to cancel the process.

If I run the application again, the firewall message does not come up again. I looked in the firewall settings at the exceptions list. I activated the exceptions for eclipse and for the jdk, but nothing changed.

How do I configure the firewall to let my application communicate or to ask me again after the admin password?

Thanks in advance.

share|improve this question

migrated from Jan 21 '10 at 2:14

This question came from our site for professional and enthusiast programmers.

Whoa. Your boss is a dictator. :o – Pikrass Jan 19 '10 at 18:11

Do you have sufficient-enough access on your machine to access the advanced settings and control app for the Windows Firewall, wf.msc?

Go to your Start menu, and then in the Search box, type wf.msc, which should find the app in your Start menu. Run it (and authorize it to run when UAC asks). You should then get a "Windows Firewall with Advanced Security" window, and on the left-hand side, you should see a few listed rulesets, including Outbound Rules. If you click on that, I suspect you'll find a rule that's denying your applet access to the outbound network; delete it, and you should be back in business.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.