Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am attempting to run a regex on my site, and I am getting this response:

Compilation failed: support for \P, \p, and \X has not been compiled at offset 1

After googling for a bit, I've found that apparently my PCRE on my server is not UTF8 enabled, and is therefore causing problems. When I ssh with pcretest -C I get

PCRE version 6.6 06-Feb-2006
Compiled with
  UTF-8 support
  No Unicode properties support
  Newline character is LF
  Internal link size = 2
  POSIX malloc threshold = 10
  Default match limit = 10000000
  Default recursion depth limit = 10000000
  Match recursion uses stack

When I do yum update pcre it tells me that there isn't anything to update.

People are telling me that I can turn on UTF-8 support...help?

I am a noob.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Check out this website.

http://gaarai.com/2009/01/31/unicode-support-on-centos-52-with-php-and-pcre/

It discusses your problem and a solution.

Hope that helps.

David

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.