Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm connected to a Nokia N810 Internet Tablet through ssh. The default $TERM value is 'xterm' which causes all sorts of key bindings messes in Vim. Specifically the arrow keys, and home/end keys print out characters or change the case when not in editing mode.

Does anyone know a sane $TERM value to fix this problem, or some other solution?

share|improve this question

4 Answers 4

up vote 2 down vote accepted

setatakahashi is correct in that you'll need a .vimrc

From a Maemo / n810 perspective you'll want at least these (amongst any of your own personal) settings in your vimrc.

set nocompatible
set t_Co=256
set t_AB=^[[48;5;%dm
set t_AF=^[[38;5;%dm

The last three options set up the colours a bit more nicely within the vim on the tablet's terminal.

You get the ^[ by pressing control-v escape.

share|improve this answer

Have you tried vt100?

share|improve this answer
    
Doesn't work, same results as TERM=xterm –  Neil May 20 '09 at 21:34

Create a .vimrc file in your home directory.

share|improve this answer

vt220 sometimes solves the problem for me

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.