Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've got a working NexentaCore Platform 2.0rc2 (OpenSolaris b104) machine, which I'm trying to bring up-to-date using apt-clone upgrade --- NCP 3.0a4 (OpenSolaris b124).

The upgrade process appears to complete successfully, however the machine reboots right after I select the new checkpoint in the GRUB menu.

When I boot the new checkpoint with "-v", I see the following messages right before the screen flickers out for reboot:

 WARNING: failed to resolve 'scsa,probe' driver alias, defaulting to 'nulldriver'
 WARNING: failed to resolve 'scsa,nodev' driver alias, defaulting to 'nulldriver'

Not sure if this is related.

Any suggestions about how I can troubleshoot this?

share|improve this question

3 Answers 3

You might want to add the -k option to the grub menu entry to have the OS falling back to mdb in case of panic. Something like:

.../unix -k -B $ZFS-BOOTFS,console=text -m verbose
share|improve this answer
    
Thanks. I've tried this, and the machine ends up at a [0]> prompt, at which point I can't do anything but hardboot (keyboard does not respond). –  smokris Jan 27 '10 at 19:26
    
What was the last message displayed just before the hang ? –  jlliagre Jan 28 '10 at 8:26

I have the same problem. A screen capture further shows:

WARNING: failed to resolve 'scsa,probe' driver alias, defaulting to 'nulldriver' WARNING: failed to resolve 'scsa,nodev' driver alias, defaulting to 'nulldriver'

/kernel/fs/amd64/zfs: undefined symbol 'lbolt' /kernel/fs/amd64/zfs: undefined symbol 'lbolt64' WARNING: mod_load: cannot load module 'zfs'

panic[cpu0]/thread=fffffffffbc2e7a0: Cannot _init zfs module

I've done some poking around, and found that the upgraded /kernel/misc/amd64/scsi and /kernel/misc/scsi both differ from the original, at least in having the 'scsa,probe' and 'scsa,nodev' strings in them. I am not sure where those strings are coming from, though. Copying those files from a known good just created a bunch of new errors.

share|improve this answer

If you guys are running AMD processors, then it may be a situation where the new kernel (as Paul Archer has identified) is getting very nit picky with the older AMD lines. I ran into this where the older AMDs would result in anywhere from random reboots to unsuccessful/failing boots.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.