Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Windows 2008 server running multiple Hyper-V guests. I want to create a Hyper-V "Internal" network. So far, I cannot get anything to communicate.

  1. I created the Internal network adapter in the Hyper-V manager
  2. I assigned each VM's network adapter to the internal network adapter
  3. I assigned an IP address to the host (10.1.0.1) with no default gateway (since it also has an external network card with a gateway)
  4. I assigned each guest VM an IP (10.1.0.x) with 10.1.0.1 (host) as the gateway
  5. I installed the Routing and Remote Access roll on the host

The problem is that neither the host or the guests and ping any other IP on the network. I have no communication at all between any of the guests. The guests in question are Windows 2008 R2 Enterprise, standard install (not Core).

What am I missing to get the host/vms to communicate via the internal network adapter?

share|improve this question
    
I should note I did extensive searching on this topic. The only page I found even close was : infotechguyz.com/server2008/hypervrouting.html. Even follow those steps exactly didn't help. –  Chris Thompson Jan 22 '10 at 4:44

1 Answer 1

up vote 3 down vote accepted
+100

If the VMs can't ping even between themselves, then something is definitely broken here, and it's not related to the RRAS service running on the host; regardless of their default gateway's behaviour, machines placed on the same network and with proper IP configuration should be able to talk at least between themselves.

Did you try disabling Windows Firewall on the guests?

Also, as per Greg Askew's suggestion, I'd try removing RRAS on the host; maybe it's messing up something with Hyper-V networking.

share|improve this answer
1  
I think you're right. He may want to remove RRAS and verify that there is connectivity between the guests, then determine if RRAS is required. –  Greg Askew Jan 24 '10 at 18:23
    
Agreed, maybe RRAS is messing things up on the host. Updated answer accordingly. –  Massimo Jan 25 '10 at 11:20
    
I disabled the firewall and all of a sudden it started working fine. I didn't do that before because I didn't have issues with the firewall when using an External network. Now I'm just trying to get NAT working so the VMs can get access to the internet through a new VM I'm setting up for RRAS/DNS/DHCP. –  Chris Thompson Jan 25 '10 at 17:31
1  
"When in doubt, disable Windows Firewall." (TM) –  Massimo Jan 25 '10 at 17:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.