Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

When I access my site by from firefox says "Connection is untrusted" and it says "the certificate is valid only for *".

But when I try to access the site, its resolving properly.

Firefox says,

This Connection is Untrusted You have asked Firefox to connect securely to, but we can't confirm that your connection is secure. Normally, when you try to connect securely, sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified.

What Should I Do?

If you usually connect to this site without problems, this error could mean that someone is trying to impersonate the site, and you shouldn't continue.

Technical Details uses an invalid security certificate.

The certificate is only valid for *

(Error code: ssl_error_bad_cert_domain)

I Understand the Risks

If you understand what's going on, you can tell Firefox to start trusting this site's identification. Even if you trust the site, this error could mean that someone is tampering with your connection.

Don't add an exception unless you know there's a good reason why this site doesn't use trusted identification.

Is there any way to avoid this error,or shall we add exception for this site.

share|improve this question

migrated from Jan 22 '10 at 8:07

This question came from our site for professional and enthusiast programmers.

3 Answers 3

an SSL certificate is only valid for a given domain - this is typically either OR Wildcard SSL certs are also available (which it appears you have in this case) which will validate *, including however still will not validate for

Solutions would be:

  • redirect from to (arguably better for SEO)
  • purchase a further SSL cert

I invariably go for the 1st option which is easily acheived in IIS or Apache

share|improve this answer
The redirect will work, but it will only work without complaint if you hit http:// and get redirected to https:// If you have a cert only for, and you hit https://", you will still get a warning that the certificate has a name mismatch before it gets redirected. – Alex Jan 22 '10 at 13:58 uses an invalid security certificate.

This seems to indicate that your browsing is attempting to contact, without the www. Unfortunately the wildcard certificate doesn't match in this case.

I don't get any warnings if I go to, which then redirects to the HTTPS-version.

So the obvious solution would be to make redirect to

share|improve this answer

The ideal solution is to get an SSL certificate from a provider that will add as a SAN in the certificate. That way, it will work for and any subdomain of without getting any errors. I believe GoDaddy, DigiCert, and Comodo can do this.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.