Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have installed Webalizer on Ubuntu with Synaptic Package Manager and it works just fine.

Then I installed Webalizer on Mac (10.6.2) with http://webalizer.darwinports.com/. But geolocation does not work.

I have parsed the exactly same log with Ubuntu and Mac, and Ubuntu finds 156 locations and Mac finds only one: Unresolved/Unknown.

FAQ in 7b. My Server doesn't do name lookups. Will The Webalizer? says to read DNS.README to figure out how to set up geolocation. I have read it and I did not understand anything.

At download page I have found the link to Latest Webalizer GeoDB database. It's readme says I should probably just copy GeoDB.dat to /usr/share/GeoDB, but that did not help. It also says:

The default location can be found by using the '-vV' command line switches of the Webalizer if you are unsure.

But that does not say where default location is.

Mac:

$ webalizer -vV
Webalizer V2.01-10 (Darwin 10.2.0) English
Copyright 1997-2001 by Bradford L. Barrett

Ubuntu:

$ webalizer -vV
Webalizer V2.01-10 (Linux 2.6.31-16-generic) locale Copyright 1997-2001 by Bradford L. Barrett

When I run webalizer on Ubuntu it says it is using geoip database (Mac does not even display that line):

$ webalizer -o report december.log
...
Using default GeoIP database
...

README says I should use -J switch to point to geolocation database, but I guess I am doing something wrong, because it tries to use geolocation file as input file:

$ webalizer -o report -J /Users/zeljko/GeoDB.dat december.log
Webalizer V2.01-10 (Darwin 10.2.0) English
Using logfile /Users/zeljko/GeoDB.dat (clf)
Creating output in report
Hostname for reports is 'mac'
Reading history file... webalizer.hist
Skipping bad record (1)
...
No valid records found!

It behaves the same on Ubuntu if I try to use downloaded geolocation database.

share|improve this question

migrated from superuser.com Jan 22 '10 at 11:48

This question came from our site for computer enthusiasts and power users.

add comment

2 Answers

up vote 2 down vote accepted
+50

Webalizer needs to be built with --enable-geoip for the geolocation to work - that darwinports version doesn't compile Webalizer with --enable-geoip. Ubuntu/Debian do, so that's why it works there.

You could compile it from scratch yourself and enable GeoIP

  • you'll need to download/compile/install the GeoIP library from here
  • then download the Webalizer source and rebuild it with ./configure --enable-geoip

DNS and GeoIP are two different things - that DNS.README Is just for getting basic DNS resolution working.

Hope that helps

share|improve this answer
    
Thanks, that helps a lot. I have tried to build Webalizer on Mac, but it was dependency hell. I required a ton of stuff to be installed. Not worth the time. I will use it on Ubuntu. –  Željko Filipin Jan 27 '10 at 10:09
add comment

You are using v2.01 which does not support geolocation.

share|improve this answer
    
Which version should I use? –  Željko Filipin Feb 5 '10 at 11:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.