Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Exactly what is the best way to configure this? I have a user account for a web app specified, but I also want to connect to the database via a GUI. The host is specified as % but the GUI tool repeatedly says access denied although I am using the proper password. If I change this to localhost then I can connect via the command line, but not via the GUI. If I add two entries, then I can connect via the command line and not the GUI. Leaving only the % doesn't let me connect via the command line OR the GUI. I want to be able to connect both on the actual server (via the web app itself) AND via the GUI tool.

share|improve this question
How are you setting the permissions? – davidcl Jan 22 '10 at 18:01
Is the GUI tool on the same host? How are you connecting, through the socket or through tcp/ip? Can you connect using the mysql command? – David Jan 22 '10 at 18:41
What's your GRANT statement look like? – Jon Haddad Jan 22 '10 at 18:50
grant all privileges on mydb.* to 'user'@'%' with grant option; – Wayne M Jan 26 '10 at 3:52
No password? Not sure if you omitted that on purpose for the comment, or if it's just missing. – Jon Haddad Jan 26 '10 at 20:02

You don't mention that you have ever been able to connect using the GUI tool. If you haven't then I suspect that the problem is not with mysql's permissions, but with the GUI tool's config.

If I'm misinterpreting, please clarify under what circumstances you were able to connect using the GUI.

share|improve this answer
Not to this server, but to other servers with the same kind of install. I've tried using two different GUIs (Sequel Pro and Navicat for MySQL) and both give me a permission denied error although I've followed the same procedure as I always have. – Wayne M Jan 22 '10 at 17:35

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.