Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a weird problem that manifests when users log onto a server via RDP and they have the "Printers" box checked in the "Local Resouces" tab of the Remote Desktop Client. Basically, the server's cpu gets maxed out to 100% trying to do something with a printer. One proven (by experience) way to solve this is to make sure that checkbox is unchecked in everybody's RDP shortcut. However, it would be much more efficient if we could disable the ability on the server somehow. (Better yet of course would be to know the root cause) Unfortunately, I don't know where to start, as I don't know what this feature's official name is. I'm not even sure whether or not I've provided enough information for you to help, but I've always had good luck with this community. Our server is running Windows 2003 R2 Service Pack 2 if that matters.

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

This article: http://www.virtualizationadmin.com/articles-tutorials/terminal-services/printing/windows-terminal-services-printing.html
describes the settings for terminal services. You can uncheck "connect client printers at logon" in the Terminal Services Configuration Administrative Tool.

share|improve this answer
    
+1 Thanks! this is exactly what i was looking for. –  Peter Jan 27 '10 at 19:06
add comment

This is a pretty common occurence on W2K & W2K3. When a user logs on to the server, the spoolsv.exe and winlogon.exe processes spike the CPU. The spoolsv.exe issue was supposed to be resolved by a hotfix several years ago, but I still see the issue ocurr on my TS servers. The issue seems to ocurr whether you're using Citrix or RDP. You can control the mapping of client printers via GPO or on the RDP protocol on the TS itself.

http://www.brianmadden.com/blogs/guestbloggers/archive/2005/02/22/war-story-the-most-important-spooler-hotfix.aspx

http://support.microsoft.com/?kbid=840371

share|improve this answer
    
+1 Thanks! this is exactly what i was looking for. (had to accept einstiien's because he was first) –  Peter Jan 27 '10 at 19:07
    
Glad to help... –  joeqwerty Jan 27 '10 at 19:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.