Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

An old machine in our office, running Ubuntu 6.06 all of a sudden will not boot up. I get the following info during boot:

Uncompressing Linux... Ok Booting the kernel
mount: Mounting /root/sda1 /root failed: No such device
mount: Mounting /root/dev on /dev/.static/dev failed: No such file or directory
mount: Mounting /sys /root/sys failed: No such file or directory
mount: Mounting /pro /root/pro failed: No such file or directory
Target filesystem doesn't have /sbin/init


Busybox v1.01 (debian 1:1.01-4ubuntu3) Built-in shell (ash)

Enter 'help' for a list of built-in commands
/bin/sh: can't access tty; job control turned off
#

I haven't changed anything on the system as far as I'm aware, and I ran some HD diagnostics and everything seems fine.

After Googling around, I found this thread: http://ubuntuforums.org/showthread.php?t=246895 Which seems very similar to my problem, however when I try to mount the drive with the following command:

sudo mount -t ext3 -o rw /dev/hda1 /mnt

I get the following error:

mount: wrong fs type, bad option, bad superblock on /dev/sda1, missing code page or helper program, or other error In some cases useful info is found in syslog - try dmesg | tail or so

I ran fdisk -l and it says the partition type is Linux.

The output after running dmesg | tail :

[12207.483801] init_special_inode: bogus i_mode (101)
[12207.483809] EXT2-fs: corrupt root inode, run e2fsck
[12260.427078] init_special_inode: bogus i_mode (101)
[12260.427086] EXT2-fs: corrupt root inode, run e2fsck
[13716.998799] e100: eth0 NIC Link is Up 100 Mbps Full Duplex
[13716.998923] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[13727.061967] eth0: no IPv6 routers present
[13896.700449] kjournald starting.  Commit interval 5 seconds
[13896.700458] init_special_inode: bogus i_mode (101)
[13896.700465] EXT3-fs: corrupt root inode, run e2fsck

After running e2fsck -p /dev/sda1, I get the following info:

/dev/sda1: clean, 142449 / 9584640 files, 5402711 / 19161520 blocks

Now I'm really not sure where to go with this :x

Thank you for looking

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Most of the time, e2fsck will not run unless it thinks it should. You can force it in a situation like this. Try adding the -f flag, like e2fsck -fp /dev/sda1.

share|improve this answer
3  
But never, ever do it on a mounted filesystem. Ever. –  Tom O'Connor Jan 23 '10 at 21:08
    
Thanks a lot, doing this instructed me to manually run fsck. I did that, and cleared the errors and now the drive will mount. :) I tried to restart the machine and I get Error 15 from GRUB. I'll play around with this and see if I can restore GRUB. –  Josh Jan 25 '10 at 20:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.