Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I want to setup the max requests to keep my system RAM from filling up when there is a memory leak.

But I dont know where it is.

share|improve this question

1 Answer 1

/etc/lighttpd/mod_fastcgi.conf:

  fastcgi.server = ( ".php" =>
      (( "socket" => "/tmp/php-fastcgi.socket",
          "bin-path" => "/usr/bin/php-cgi",
          "max-procs" => 10,
          "bin-environment" => (
              "PHP_FCGI_CHILDREN" => "16",
              "PHP_FCGI_MAX_REQUESTS" => "1000" 
          ),
          "broken-scriptfilename" => "enable" 
      ))
  )

It works fine for me.

Lighttpd - Docs:PerformanceFastCGI - lighty labs

share|improve this answer
2  
It's also recommended that you set PHP_FCGI_MAX_REQUESTS to 500 or so in the very next part of the FAQ. –  sybreon Feb 24 '10 at 16:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.