Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have come across this problem before, it doesn't generally get in the way too much but i would really like to know why it happens.

I am running SBS 2008, i changed the Bindings for the Sharepoint intranet so that instead of browing it via server-name:987 i can browse it on port 80 using the host header intranet.localdomain.local (for which an A record has been configured in DNS).

When client computers browse to intranet.localdomain.local it then asks them to authenitcate which they do with their windows credentials and ta da it works no problem. When i browse to intranet.localdomain.local on the SBS server it doesn't authenticate with windows credentials. It just doesn't work. If i browse to it using the original server-name:987 then it works fine.

Does anybody know why this is?

share|improve this question
    
What happens when you login locally and browse to the server? Also, when you say "When client computers" are you indicating that other users don't have the same issue. If so do you have different NTFS credentials than those users? –  Fergus Dec 21 '10 at 6:14

1 Answer 1

This sounds like a LoopBack security check problem. Have you tried adding the Disable Loopback Check reg key (if it isn't already added)?

See this article for a great explanation and provides guidance. That being said, this particular "problem" is actually recognized as a security "feature", so exercise caution when deciding to disable it.

http://www.harbar.net/archive/2009/07/02/disableloopbackcheck-amp-sharepoint-what-every-admin-and-developer-should-know.aspx

Good luck! Hope that helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.