Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I recently upgraded to Snow Leopard, and I want to start using the included Apache web server. I activated web sharing, and went to http:/127.0.0.1/ in my web browser. Safari couldn't connect to the server. Finally, using Network Utility, I found:

Port Scanning host: 127.0.0.1
Open TCP Port:  21          ftp
Open TCP Port:  22          ssh
Open TCP Port:  631         ipp
Open TCP Port:  3306        mysql
...and so on...

I tried the same thing for 10.0.1.34, which is my LAN IP. Unless I'm very mistaken, this means that TCP Port 80 is not open on my computer. My 2wire router is forwarding port 80 to port 80 on 10.0.1.34, like it should be. My OS X Firewall is off, according to its Preferences pane.

How do I open up TCP Port 80?


EDIT: Well, it's semi fixed. I think it's a problem with the Apache server itself. I realized that I still had a copy of my old setup from OS X Tiger in /user/local/apache2. I ran the server in that location, changing the User and Group names in httpd.conf to "_www" as in the Snow Leopard default, and it worked great.

A weird hint that led me to that conclusion: the log files from the standard Snow Leopard setup of Apache hadn't been created. I assume that Apache ran into trouble before it could even start up (but for some reason didn't leave much evidence as to what went wrong).

share|improve this question

1 Answer 1

Activating web sharing should be enough to get it running. Unless you've screwed with the config and messed something up.

I just tried it, and on 127.0.0.1 I see the default Apache landing page.

Is there any possiblity that under Security->Firewall->Advanced that you've clicked the checkbox that says "block all incoming connections"?

share|improve this answer
    
I second that. Do you have some third party firewall running? –  einstiien Jan 23 '10 at 20:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.