Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I had a Fedora box running using my static IP 69.169.136.6, etc, all configured according to what the ISP required. Just recently the hard drive failed (and I should have been keeping better backups) - while it is being recovered I would like to put up a webpage on my Archlinux PC explaining the problem - I presently do not have sufficient access to change the DNS record assigned to the domain.

When I change my ip address while my system is running to 69.169.136.6, ifconfig reports the new ip address, but http://whatismyip.com/ does not. When I change it and reboot, I can't ping - the message I recieve is "connect: Network is unreachable" (when given one of google.com 's IP addresses - hostnames give me ping: unknown host xxx). Until I have access to the DNS system, what can I do to make this work?

Edit: With new IP address, same problem, IP is now 69.169.136.29. Some commands might be useful:

#ping 69.169.136.1
PING 69.169.136.1 (69.169.136.1) 56(84) bytes of data.
64 bytes from 69.169.136.1: icmp_seq=1 ttl=64 time=0.377 ms

#ping 69.169.190.211
connect: Network is unreachable
#ping 208.72.160.67
connect: Network is unreachable

#ifconfig
eth0      Link encap:Ethernet  HWaddr 00:E0:4D:97:23:9B  
          inet addr:69.169.136.29  Bcast:69.169.137.255  Mask:255.255.254.0
          inet6 addr: fe80::2e0:4dff:fe97:239b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:132091 errors:0 dropped:0 overruns:0 frame:0
          TX packets:17 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:9635179 (9.1 Mb)  TX bytes:1322 (1.2 Kb)
          Interrupt:29 Base address:0x6000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:48 errors:0 dropped:0 overruns:0 frame:0
          TX packets:48 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:2480 (2.4 Kb)  TX bytes:2480 (2.4 Kb)

#ip route
69.169.136.0/23 dev eth0  proto kernel  scope link  src 69.169.136.29 

#cat /etc/resolv.conf
# Generated by dhcpcd
#nameserver 208.67.222.222
#nameserver 208.67.220.220
nameserver 69.169.190.211
nameserver 208.72.160.67

# /etc/resolv.conf.tail can replace this line

Update: have new static IP addresses, verified to work in Windows... Relevant portions of /etc/rc.conf below:

#Static IP example
#eth0="eth0 69.169.136.6 netmask 255.255.254.0 broadcast 69.169.136.1"
#eth0="eth0 69.169.136.29 netmask 255.255.254.0 broadcast 69.169.137.255"
eth0="eth0 69.169.136.32 netmask 255.255.254.0 broadcast 69.169.137.255"
#eth0="dhcp"
INTERFACES=(eth0)

# Routes to start at boot-up (in this order)
# Declare each route then list in ROUTES
#   - prefix an entry in ROUTES with a ! to disable it
#
#gateway="default gw 192.168.0.1"
gateway="default gw 69.169.136.1"
#gateway="69.169.136.1"
ROUTES=(!gateway)
#ROUTES=()
share|improve this question
    
Seen in the last file, the problem was the presence of the ! in ROUTES=(!gateway) - should have been ROUTES=(gateway). #LFMF –  michaelc Mar 30 '10 at 8:24

2 Answers 2

up vote 1 down vote accepted

From the output of your ip route you don't have the default gateway set - try running:

ip route add default via 69.169.136.1

I'm not sure if it's different on archlinux, but on the Redhat variants to make that permenant you can add the following to /etc/sysconfig/network:

GATEWAY=69.169.136.1
share|improve this answer
    
Using that command, I was able to gain connectivity through the static IP. Now I just have to figure out how to make it permanent. –  michaelc Mar 30 '10 at 8:17
    
Read over the relevant portion of wiki.archlinux.org/index.php/Configuring_Network#For_Static_IP again, was a classic PEBKAC; I'd not noticed the absence of the ! in the ROUTES command when using a static IP. Thank you both for your help. –  michaelc Mar 30 '10 at 8:22

check your network settings:

  • is your network mask and broadcast address set correctly?
  • is your default gateway set correctly?
share|improve this answer
    
Yes to both - I called up my ISP to verify (was what took so long to reply). –  michaelc Jan 26 '10 at 1:25
    
try how far you can go with your network config. try to ping your gateway. when this works try to ping your dns servers, and so on. when pinging your default gw fails, look at your ip, netmask and routes. when pinging your dns fails, try to telnet on dns port. when this fails, take a look at your firewall rules. this way it should be possible to pinpoint your problem. –  Christian Jan 26 '10 at 7:32
    
Still no contact with ISP :P. They keep promising to call back. –  michaelc Mar 1 '10 at 10:55
    
please add the output of the following commands to your question: ifconfig, ip route and cat /etc/resolv.conf. –  Christian Mar 1 '10 at 14:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.